summaryrefslogtreecommitdiff
path: root/firmware/Cargo.toml
diff options
context:
space:
mode:
authorMarc Poulhiès <dkm@kataplop.net>2020-09-02 16:06:58 +0200
committerMarc Poulhiès <dkm@kataplop.net>2020-11-11 21:18:38 +0100
commit091566813df47450a6fca945339cd1e1ba90c915 (patch)
treea72489949e08ab67a9bd265ecdc3d6b24d43b1ff /firmware/Cargo.toml
parent5be1a9fbf95cbbc1300f24f77f049c93480b3854 (diff)
Initial work for Pouetpouet board
Based on keyseebee but now very different.
Diffstat (limited to 'firmware/Cargo.toml')
-rw-r--r--firmware/Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/firmware/Cargo.toml b/firmware/Cargo.toml
index 1da11be..2fd5d7b 100644
--- a/firmware/Cargo.toml
+++ b/firmware/Cargo.toml
@@ -1,11 +1,12 @@
[package]
-name = "keyseebee"
+name = "pouetpouet"
version = "0.1.0"
-authors = ["Guillaume Pinot <texitoi@texitoi.eu>"]
+authors = ["Marc Poulhiès <dkm@kataplop.net>", "Guillaume Pinot <texitoi@texitoi.eu>"]
edition = "2018"
[dependencies]
-stm32f0xx-hal = { version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
+stm32f0xx-hal = { git = "https://github.com/dkm/stm32f0xx-hal/", features = ["rt", "stm32f072", "stm32-usbd"] }
+##{ version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
cortex-m = "0.6"
cortex-m-rt = { version = "0.6.10", features = ["device"] }
panic-halt = "0.2.0"
@@ -15,6 +16,8 @@ generic-array = "0.13"
embedded-hal = "0.2"
usb-device = "0.2.0"
nb = "1.0.0"
+ws2812-spi = "0.3.0"
+smart-leds = "0.3.0"
[profile.release]
lto = true