summaryrefslogtreecommitdiff
path: root/firmware/Cargo.toml
diff options
context:
space:
mode:
authorMarc Poulhiès <dkm@kataplop.net>2021-01-03 14:56:01 +0100
committerMarc Poulhiès <dkm@kataplop.net>2021-01-10 15:41:10 +0100
commit1d18cc24607724e3d6987b3701fa8667e3976ee7 (patch)
tree38039e725d5cc19312fb4fea5db53ed92010d2cf /firmware/Cargo.toml
parent4e71a432f3729e1477e362b1a302b13ad80575f8 (diff)
Allow for minor version change in dependencies
Diffstat (limited to 'firmware/Cargo.toml')
-rw-r--r--firmware/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/firmware/Cargo.toml b/firmware/Cargo.toml
index 5db1fba..9086d9b 100644
--- a/firmware/Cargo.toml
+++ b/firmware/Cargo.toml
@@ -8,16 +8,16 @@ edition = "2018"
stm32f0xx-hal = { git = "https://github.com/dkm/stm32f0xx-hal/", features = ["rt", "stm32f072", "stm32-usbd"] }
##{ version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
cortex-m = "0.6"
-cortex-m-rt = { version = "0.6.10", features = ["device"] }
-panic-halt = "0.2.0"
+cortex-m-rt = { version = "0.6", features = ["device"] }
+panic-halt = "0.2"
keyberon = { git = "https://github.com/dkm/keyberon" }
cortex-m-rtic = "0.5"
generic-array = "0.13"
embedded-hal = "0.2"
-usb-device = "0.2.0"
-nb = "1.0.0"
-ws2812-spi = "0.3.0"
-smart-leds = "0.3.0"
+usb-device = "0.2"
+nb = "1.0"
+ws2812-spi = "0.3"
+smart-leds = "0.3"
[profile.release]
lto = true