summaryrefslogtreecommitdiff
path: root/firmware/Cargo.toml
diff options
context:
space:
mode:
authorMarc Poulhiès <dkm@kataplop.net>2021-05-19 14:33:56 +0200
committerMarc Poulhiès <dkm@kataplop.net>2021-05-19 14:33:56 +0200
commit29fa9b6732f32342bb8f3e93f4da29a9c519e3f4 (patch)
tree6791d15d73a25c031a2cfda24064d22f70a31069 /firmware/Cargo.toml
parentd5fbdb49a5b472bb91ce988a9c6c8018dd74cddd (diff)
Use new macro to define layers + cleaning
Use the new layout!() macro for easier and more readable layers definitions. Add a testmode feature, used to have 'a' on all keys, easier to test if all switch are correctly working or not. Also fixed some minor warnings.
Diffstat (limited to 'firmware/Cargo.toml')
-rw-r--r--firmware/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/firmware/Cargo.toml b/firmware/Cargo.toml
index 6530914..b93b6f3 100644
--- a/firmware/Cargo.toml
+++ b/firmware/Cargo.toml
@@ -24,3 +24,8 @@ lto = true
incremental = false
opt-level = "z"
debug = true
+
+[features]
+default = [ ]
+
+testmode = [ ]