summaryrefslogtreecommitdiff
path: root/firmware/Cargo.toml
diff options
context:
space:
mode:
authorMarc Poulhiès <dkm@kataplop.net>2022-02-25 22:39:32 +0100
committerMarc Poulhiès <dkm@kataplop.net>2022-02-25 22:40:01 +0100
commitb79621076080ee1518189aa9f8788780f618aa21 (patch)
tree86841a97f361f76f0a99b5348e378ee843ebf273 /firmware/Cargo.toml
parentf3f30603ec08b6a54d85f75d140beca1de85a352 (diff)
Update some dependencies
Signed-off-by: Marc Poulhiès <dkm@kataplop.net>
Diffstat (limited to 'firmware/Cargo.toml')
-rw-r--r--firmware/Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/firmware/Cargo.toml b/firmware/Cargo.toml
index b93b6f3..5cc1170 100644
--- a/firmware/Cargo.toml
+++ b/firmware/Cargo.toml
@@ -6,17 +6,16 @@ edition = "2018"
[dependencies]
stm32f0xx-hal = { git = "https://github.com/dkm/stm32f0xx-hal/", features = ["rt", "stm32f072", "stm32-usbd"] }
-##{ version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
+##stm32f0xx-hal = { version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
cortex-m = "0.6"
cortex-m-rt = { version = "0.6", features = ["device"] }
panic-halt = "0.2"
keyberon = { git = "https://github.com/TeXiToi/keyberon" }
-cortex-m-rtic = "0.5"
-generic-array = "0.13"
+cortex-m-rtic = { version = "0.5.8", default-features = false, features = ["cortex-m-7"] }
embedded-hal = "0.2"
usb-device = "0.2"
nb = "1.0"
-ws2812-spi = "0.3"
+ws2812-spi = "0.4"
smart-leds = "0.3"
[profile.release]