summaryrefslogtreecommitdiff
path: root/firmware/rust/Cargo.toml
diff options
context:
space:
mode:
authorMarc Poulhiès <dkm@kataplop.net>2022-07-07 21:51:38 +0200
committerMarc Poulhiès <dkm@kataplop.net>2022-07-22 21:06:23 +0200
commit3c71e3a2a3af39d579c2649fddf0c8ba835bfa01 (patch)
treef383b855123ae2fb66ebb3537d36153388418ca8 /firmware/rust/Cargo.toml
parent972760b3e68156c72129b833d5624d4e6f60619b (diff)
Move rust firmware in subdir
... for the upcoming Ada one.
Diffstat (limited to 'firmware/rust/Cargo.toml')
-rw-r--r--firmware/rust/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/firmware/rust/Cargo.toml b/firmware/rust/Cargo.toml
new file mode 100644
index 0000000..54f44cc
--- /dev/null
+++ b/firmware/rust/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+name = "pouetpouet"
+version = "0.1.0"
+authors = ["Marc Poulhiès <dkm@kataplop.net>", "Guillaume Pinot <texitoi@texitoi.eu>"]
+edition = "2018"
+
+[dependencies]
+stm32f0xx-hal = { git = "https://github.com/dkm/stm32f0xx-hal/", features = ["rt", "stm32f072", "stm32-usbd"] }
+##stm32f0xx-hal = { version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
+cortex-m = "0.7"
+cortex-m-rt = { version = "0.7", features = ["device"] }
+panic-halt = "0.2"
+keyberon = { git = "https://github.com/TeXiToi/keyberon" }
+cortex-m-rtic = { version = "0.5", default-features = false, features = ["cortex-m-7"] }
+embedded-hal = "0.2"
+usb-device = "0.2"
+nb = "1.0"
+ws2812-spi = "0.4"
+smart-leds = "0.3"
+
+[profile.release]
+lto = true
+incremental = false
+opt-level = "z"
+debug = true
+
+[features]
+default = [ ]
+testmode = [ ]