summaryrefslogtreecommitdiff
path: root/firmware/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/Cargo.toml')
-rw-r--r--firmware/Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/firmware/Cargo.toml b/firmware/Cargo.toml
index 1da11be..2fd5d7b 100644
--- a/firmware/Cargo.toml
+++ b/firmware/Cargo.toml
@@ -1,11 +1,12 @@
[package]
-name = "keyseebee"
+name = "pouetpouet"
version = "0.1.0"
-authors = ["Guillaume Pinot <texitoi@texitoi.eu>"]
+authors = ["Marc Poulhiès <dkm@kataplop.net>", "Guillaume Pinot <texitoi@texitoi.eu>"]
edition = "2018"
[dependencies]
-stm32f0xx-hal = { version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
+stm32f0xx-hal = { git = "https://github.com/dkm/stm32f0xx-hal/", features = ["rt", "stm32f072", "stm32-usbd"] }
+##{ version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
cortex-m = "0.6"
cortex-m-rt = { version = "0.6.10", features = ["device"] }
panic-halt = "0.2.0"
@@ -15,6 +16,8 @@ generic-array = "0.13"
embedded-hal = "0.2"
usb-device = "0.2.0"
nb = "1.0.0"
+ws2812-spi = "0.3.0"
+smart-leds = "0.3.0"
[profile.release]
lto = true