summaryrefslogtreecommitdiff
path: root/firmware/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/Cargo.toml')
-rw-r--r--firmware/Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/firmware/Cargo.toml b/firmware/Cargo.toml
index 5cc1170..54f44cc 100644
--- a/firmware/Cargo.toml
+++ b/firmware/Cargo.toml
@@ -7,11 +7,11 @@ edition = "2018"
[dependencies]
stm32f0xx-hal = { git = "https://github.com/dkm/stm32f0xx-hal/", features = ["rt", "stm32f072", "stm32-usbd"] }
##stm32f0xx-hal = { version = "0.17.0", features = ["rt", "stm32f072", "stm32-usbd"] }
-cortex-m = "0.6"
-cortex-m-rt = { version = "0.6", features = ["device"] }
+cortex-m = "0.7"
+cortex-m-rt = { version = "0.7", features = ["device"] }
panic-halt = "0.2"
keyberon = { git = "https://github.com/TeXiToi/keyberon" }
-cortex-m-rtic = { version = "0.5.8", default-features = false, features = ["cortex-m-7"] }
+cortex-m-rtic = { version = "0.5", default-features = false, features = ["cortex-m-7"] }
embedded-hal = "0.2"
usb-device = "0.2"
nb = "1.0"
@@ -26,5 +26,4 @@ debug = true
[features]
default = [ ]
-
testmode = [ ]