You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

41 lines
1.3 KiB

sudo: required
dist: trusty
language: generic
cache: apt
env:
global:
- NPROC_MAX=8
matrix:
- BUILDTEST_MCU_GROUP=static-tests
- BUILDTEST_MCU_GROUP=cortex_m4_2
- BUILDTEST_MCU_GROUP=cortex_m4_1
- BUILDTEST_MCU_GROUP=cortex_m0_2
- BUILDTEST_MCU_GROUP=cortex_m0_1
- BUILDTEST_MCU_GROUP=x86
- BUILDTEST_MCU_GROUP=cortex_m3_2
- BUILDTEST_MCU_GROUP=cortex_m3_1
- BUILDTEST_MCU_GROUP=avr8
- BUILDTEST_MCU_GROUP=msp430
- BUILDTEST_MCU_GROUP=arm7
before_install:
- source ./dist/tools/pr_check/check_labels.sh
- test -z "$TRAVIS_PULL_REQUEST" || test "$BUILDTEST_MCU_GROUP" = "static-tests" || check_gh_label "Ready for CI build" || exit 1
- sudo add-apt-repository -y ppa:terry.guo/gcc-arm-embedded
- sudo apt-get update -qq
install:
- sudo apt-get -y install $(./dist/tools/travis-scripts/get-pkg-list.py)
- sudo pip install pexpect # current version in Ubuntu repos is errorneous
- git config --global user.email "travis@example.com"
- git config --global user.name "Travis CI"
- test "$TRAVIS_BRANCH" = "master" || git fetch origin $TRAVIS_BRANCH:$TRAVIS_BRANCH
script:
- ./dist/tools/travis-scripts/build_and_test.sh
notifications:
email: false