Browse Source

Disallow PPS SPE ABI

with GCC 9+ and GLIBC 2.30+, they no longer support it.

Signed-off-by: Alexey Neyman <stilor@att.net>
master-next
Alexey Neyman 3 years ago
parent
commit
29422b2eda
  1. 4
      config/arch/powerpc.in
  2. 2
      packages/gcc/package.desc

4
config/arch/powerpc.in

@ -43,6 +43,8 @@ config ARCH_powerpc_ABI_EABI
config ARCH_powerpc_ABI_SPE
bool
prompt "SPE"
select GCC_REQUIRE_8_or_older
select GLIBC_REQUIRE_2_29_or_older
help
Add support for the Signal Processing Engine. This will set up
the toolchain so that it supports the SPE ABI extensions. This
@ -55,4 +57,6 @@ config ARCH_powerpc_ABI_SPE
and "--enable-e500_double" to your CC_EXTRA_CONFIG_ARRAY, so you
do not need to explicitly add them.
Support for SPE ABI has been removed in GCC 9.
endchoice

2
packages/gcc/package.desc

@ -2,5 +2,5 @@ repository='svn svn://gcc.gnu.org/svn/gcc'
mirrors='$(CT_Mirrors GNU gcc/gcc-${CT_GCC_VERSION}) $(CT_Mirrors sourceware gcc/releases/gcc-${CT_GCC_VERSION})'
relevantpattern='4.*|. *|.'
origin='GNU'
milestones='4.8 4.9 5 6 7'
milestones='4.8 4.9 5 6 7 8'
archive_formats='.tar.xz .tar.gz'

Loading…
Cancel
Save