Browse Source

Supply "very old" and "very new" glibc versions

... as 1.0 and 99.99, respectively, to gcc configure.

Fixes #1031.

Signed-off-by: Alexey Neyman <stilor@att.net>
dev-linux
Alexey Neyman 4 years ago
parent
commit
782b45d0da
  1. 6
      scripts/build/cc/gcc.sh

6
scripts/build/cc/gcc.sh

@ -468,7 +468,11 @@ do_gcc_core_backend() {
local glibc_version
CT_GetPkgVersion GLIBC glibc_version
glibc_version=`echo "${glibc_version}" | sed 's/\([1-9][0-9]*\.[1-9][0-9]*\).*/\1/'`
case "${glibc_version}" in
new) glibc_version=99.99;;
old) glibc_version=1.0;;
*) glibc_version=`echo "${glibc_version}" | sed 's/\([1-9][0-9]*\.[1-9][0-9]*\).*/\1/'`;;
esac
extra_config+=("--with-glibc-version=${glibc_version}")
fi

Loading…
Cancel
Save